1. Minecraft Middle Earth is a Minecraft community that recreates the world described by JRR Tolkien and his writings. Everyone can participate in organized events in which we collaborate to create major landmarks, terrain, caves, castles, towns, farms and more.

    To get started, visit The New Player Guide
    Dismiss Notice

Build server moves to 1.8 beta

Discussion in 'Development Blogs' started by q220, Sep 9, 2015.

  1. q220

    q220 Eru Iluvatar
    Staff Member

    Joined:
    Mar 1, 2014
    Messages:
    987
    Likes Received:
    1,822
    Currently the build server is running a 1.8 version of Minecraft, some plugins were a real pain to get working so expect bugs/flaws.

    +++Minecraft changes+++

    - Updated Minecraft server software to 1.8.8

    + Plugin Updates +
    Essentials:
    - Fixes so it will run on MC1.8, might lack item name support.
    EssentialsChat:
    - Fixes so it will run on MC1.8
    Freebuild:
    - Updated plugin so Themed Build plots can only generate on the Themed-Build world. This should prevent irrecoverable damage to non-tb worlds when making a mistake.
    Multiverse:
    - Language corrections
    - Permission fixes
    - Now can manage teleportion from non mv worlds to mv worlds
    MyWarp:
    - Now supports UUIDs.
    PermissionsEx: 1.22.6 > 1.23.3
    - Revert changes to CachingData to prevent rare cases of records not updating.
    - Readded timed groups.
    - Fix for ladder-fetching.
    - Performance increased for file back-end and bug tweaks.
    - Change Guava to more recent version to support MC1.8
    - Using UUID convert command should work fine on data that already has UUIDs.
    Prism: 2.0.1
    - Prism support has been halted by the developer, no changes have been made. Using a costumized prism version which should allow new items to be tracked.
    ResourceRegions: 1.1
    - No changes have been made.
    TheGaffer: 2.3.0
    - No changes have been made.
    TheHelper: 1.5
    - No changes have been made.
    Tours: 2.5.4 >
    - Fixes issue where Tours wouldn't work properly if your sentence started with a name.
    VanishNoPacket: 3.19.1
    - No changes have been made.
    VoxelSniper: 5.170 >
    - Switching to VoxelSniper 7 instead of 5, where support has been dropped. Voxelsniper 7 is a complete rewrite, but still in development. Sticking to 5.x as 7 is terribly broken.
    WorldEdit:
    - Added rotation values to lit redstone torches
    - Changed cycler tool to use undo sessions rather than changing the world directly.
    - Changed PermissionsEx support to use UUIDs wherever possible.
    - Fixed imprecise rotations.
    - Fixed entitiy rotation floating point issues.
    - Fixed button rotation and added support for up/down flipping.
    - Fixed armor stands being included through the butcher command by default.
    - Fixed performance issues with some commands that use lists of entities.
    WorldGuard: 5.9 > 6.1
    - UUID support has been added.
    - Build protection for regions is now more complete, and WorldGuard will protect against any entity and block changes as if they were players.
    - Added exit-via-teleport flag to control exiting an exit=deny region via teleportion.
    - Added fall-damage flag
    - Added time-lock flag to lock a player's time of day in a region.
    - Added weather-lock.

    If you encounter problems or issues please post them at http://www.mcmiddleearth.com/forums/suggestions-and-issues-submission-publicly.51/

    For the sake of overview, I will update this post from time to time with the biggest culprits.

    ** Issues / Problems **
    • MyWarp teleportation through constructions button/lever -> signs no longer works. This effectively broke new player world, but this is now fixed. Other places might still have this.
    • Armorstands are not tracked, nor can they be rolled back.
     
  2. kisos

    kisos Yellow flower puncher

    Joined:
    Mar 2, 2014
    Messages:
    436
    Likes Received:
    917
    saplings grow now, so the beet texture for jungle saplings grow into trees. =bad :(
     
  3. TheSpeedy_

    TheSpeedy_ Dirt Conaisseur

    Joined:
    Mar 17, 2014
    Messages:
    575
    Likes Received:
    1,443
  4. PINT00

    PINT00 Yellow flower puncher

    Joined:
    Aug 25, 2014
    Messages:
    100
    Likes Received:
    159
    Does this mean we can speedy fly now!?
     
  5. Wodleth

    Wodleth Designer
    Staff Member Designer Donor

    Joined:
    Mar 1, 2014
    Messages:
    539
    Likes Received:
    1,149
    No, because speedfly is recognized as flymod, which only staff can use
     
  6. TheSpeedy_

    TheSpeedy_ Dirt Conaisseur

    Joined:
    Mar 17, 2014
    Messages:
    575
    Likes Received:
    1,443
    Who told you about SpeedyFly(tm)??? That was a secret project that was under wraps! Now the world knows!!! The Speedy Stop Inc will be hiring a team of lawyers to see an end to this!
     
    Davidisc and mandolore100 like this.
  7. Ardelenia

    Ardelenia Yellow flower puncher

    Joined:
    Mar 1, 2014
    Messages:
    569
    Likes Received:
    1,070
    yes, empirically
     
  8. DSESGH

    DSESGH Dirt Conaisseur

    Joined:
    Mar 2, 2014
    Messages:
    1,219
    Likes Received:
    1,821
    Well, I don't want to make a new thread for this issue, so I'll post it here:
    I don't have essentials.tp.position any more.
     
  9. Ardelenia

    Ardelenia Yellow flower puncher

    Joined:
    Mar 1, 2014
    Messages:
    569
    Likes Received:
    1,070
    Is it possible to disable the water-absorbing capability of sponges? It currently works which means we can't use sponges in or near water.
     
  10. Ardelenia

    Ardelenia Yellow flower puncher

    Joined:
    Mar 1, 2014
    Messages:
    569
    Likes Received:
    1,070
    Also iron doors appear to be broken? Jacen and I tried with buttons, a lever, and a pressure plate, but the door would not open.
     
  11. Finrod_Amandil

    Finrod_Amandil Head Designer
    Staff Member Head Designer Designer Donor Media Team

    Joined:
    Mar 2, 2014
    Messages:
    2,746
    Likes Received:
    5,772
    Is there any iron doors that should operatable? They wont work cuz I added no physics to them so we can stack them
     
  12. _Luk

    _Luk One of Us

    Joined:
    Mar 1, 2014
    Messages:
    564
    Likes Received:
    1,029
    yessssss, cough helms deep cough
     
  13. Ardelenia

    Ardelenia Yellow flower puncher

    Joined:
    Mar 1, 2014
    Messages:
    569
    Likes Received:
    1,070
    some, also many of the easter egg-y things which of course arent essential but are fun.
     
  14. Finrod_Amandil

    Finrod_Amandil Head Designer
    Staff Member Head Designer Designer Donor Media Team

    Joined:
    Mar 2, 2014
    Messages:
    2,746
    Likes Received:
    5,772
    alright ill revert that setting then
    OK the revert command (/bf npremove 71) does not seem to work properly, but as fix I can move the texture to one of the new doors.
     
    #14 Finrod_Amandil, Oct 6, 2015
    Last edited: Oct 6, 2015
    Ardelenia likes this.