Cant join server

  • Minecraft Middle Earth is a Minecraft community that recreates the world described by JRR Tolkien and his writings. Everyone can participate in organized events in which we collaborate to create major landmarks, terrain, caves, castles, towns, farms and more.

    To get started, visit The New Player Guide

Brownieb79

Starting Adventurer
Jul 19, 2018
3
0
6
Languages
English
#1
Everytime I try to join, it says "Outdated server! I'm still on1.12.2"
 

RubenPieterMark

Hardcore MCME-er
Media Team
Mar 12, 2016
651
839
41
15
The glorious Kingdom of the Netherlands
Languages
Dutch, English, French, German
#2
Everytime I try to join, it says "Outdated server! I'm still on1.12.2"
If it says it runs on 1.12.2, you should launch minecraft with 1.12.2. You probably launched 'Latest' which is 1.13, but MCME hasn't updated yet.
If you don't know how to change your version: in the launcher, instead of clicking 'PLAY' in the green box, go to 'Launcher options' and click on 'New Version'. Select 1.12.2, and confirm etc. Now go back to the 'News' tab and select the 1.12.2 version, with the arrow next to 'PLAY', in the green box.
But you probably already knew this