1. Minecraft Middle Earth is a Minecraft community that recreates the world described by JRR Tolkien and his writings. Everyone can participate in organized events in which we collaborate to create major landmarks, terrain, caves, castles, towns, farms and more.

    To get started, visit The New Player Guide
    Dismiss Notice

Connection Lost Internal Exception: java.lang.IllegalArgumentException: Parameter 'directory'

Discussion in 'Get Help' started by plum_jackson, Jun 16, 2015.

  1. plum_jackson

    plum_jackson Aspiring Commoner

    Joined:
    Jun 16, 2015
    Messages:
    3
    Likes Received:
    0
  2. q220

    q220 Eru Iluvatar
    Staff Member

    Joined:
    Mar 1, 2014
    Messages:
    988
    Likes Received:
    1,822
    This can be caused because our servers automatically sends you resource packs, this is called "Server resource packs". The error you describe is most likely caused because of a non-existent server-texture-packs folder.

    You can try to fix it by going to /User/AppData/Roaming/.minecraft folder and checking if theres a folder called server-texture-packs. If it's not there, manually create it and try joining again.
     
    plum_jackson likes this.
  3. plum_jackson

    plum_jackson Aspiring Commoner

    Joined:
    Jun 16, 2015
    Messages:
    3
    Likes Received:
    0
    Wow thanks for the quick reply!

    I'd love to see how this server has changed, I used to be active back in 2013 or so. Glad I can finally come back.
     
  4. plum_jackson

    plum_jackson Aspiring Commoner

    Joined:
    Jun 16, 2015
    Messages:
    3
    Likes Received:
    0
    It still didn't work :(

    Maybe if I disabled the automatic resource pack switch it would work. Any further suggestions?
     
  5. Finrod_Amandil

    Finrod_Amandil Head Designer
    Staff Member Head Designer Designer Donor Media Team

    Joined:
    Mar 2, 2014
    Messages:
    2,745
    Likes Received:
    5,772
    Yes try to disable the server resource packs. For that, in the server list (after you clicked "Multiplayer" on the start screen). Select the server by clicking once on it and then hit the "edit" button below. Then change the setting "Server Resource Packs" to Disabled. You then can download the RPs manually >>here<<.
     
  6. Eriol_Eandur

    Eriol_Eandur Designer
    Staff Member Designer Developer Donor Media Team

    Joined:
    Sep 19, 2014
    Messages:
    1,612
    Likes Received:
    2,685
    I think the directory name must be "server-resource-packs"
     
    Puffin4Tom likes this.
  7. q220

    q220 Eru Iluvatar
    Staff Member

    Joined:
    Mar 1, 2014
    Messages:
    988
    Likes Received:
    1,822
    Oh yeah. I just checked. Older versions (even when the term resourcepack already was in use) still used server-texture-packs. This is the folder you need:

    2015-06-23 19_33_35-.minecraft.png