Shaders

  • Minecraft Middle Earth is a Minecraft community that recreates the world described by JRR Tolkien and his writings. Everyone can participate in organized events in which we collaborate to create major landmarks, terrain, caves, castles, towns, farms and more.

    To get started, visit The New Player Guide
Status
Not open for further replies.

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#1
So, I got a new laptop today :)D), and I was trying to get shaders on it. I got forge, optifine, and the shaders mod successfully, but when I try to use any SEUS shaders, minecraft crashes. When other shaders are enabled, they simply don't do anything. Any help that you can offer would be appreciated:)

My computer has an i7 Quad Core processor and an NVIDIA GeForce 840M graphics card.
I have tried the latest versions of Optifine 1.7.2, Forge 1.7.2, and the Shaders Mod 1.7.2, and also:
  • Optifine HD_1.7.2_U_C2
  • ShadersModCore-v2.3.4-mc1.7.2-f1019
  • Forge release 1.7.2-Forge10.12.0.1019
Thanks in advance!
 

Fornad

Hardcore MCME-er
Mar 1, 2014
194
954
23
23
#2
You don't need Forge to run shaders any more. Try to install shaders and Optifine without it, and see how that goes.
 

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#3
You don't need Forge to run shaders any more. Try to install shaders and Optifine without it, and see how that goes.
Well now SEUS v10.0 Lite works, but it seems to be the only shader that does. Could my problem be a result of the OpenGL version or a graphics card setting?

My graphics card is a GeForce 840M with 2gb of dedicated memory, so as far as my knowledge goes, the card's capabilities shouldn't be the problem. Correct me if I'm wrong, though.

Again, thanks for helping
 

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#5
It could be a driver problem. Can you post the crash report?
This is the important part, as far as I know:

[11:07:17] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program gbuffers_textured_lit
[11:07:20] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program composite

The rest of the crash log is in this spoiler, just in case it helps
[11:06:33] [main/INFO]: Loading tweak class name optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Using primary tweak class name optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Loading tweak class name shadersmodcore.loading.SMCTweaker
[11:06:33] [main/INFO]: Calling tweak class optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Calling tweak class shadersmodcore.loading.SMCTweaker
[11:06:33] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[11:06:34] [main/INFO]: Setting user: DSESGH
[11:06:34] [main/INFO]: (Session ID is token:67bea4fb8df049108def3bbff17b3473:e5f1da93b135488abd361cff4631120e)
[11:06:35] [Client thread/INFO]: LWJGL Version: 2.9.1
[11:06:36] [Client thread/INFO]: Reloading ResourceManager: Default, Gondor.zip
[11:06:37] [Sound Library Loader/INFO]: Sound engine started
[11:06:39] [Client thread/ERROR]: Using missing texture, unable to load minecraft:textures/blocks/97.png, java.io.FileNotFoundException
[11:06:40] [Client thread/INFO]: Created: 1024x512 textures/blocks-atlas
[11:06:43] [Client thread/INFO]: Created: 512x256 textures/items-atlas
[11:07:13] [Server thread/INFO]: Starting integrated minecraft server version 1.7.4
[11:07:13] [Server thread/INFO]: Generating keypair
[11:07:13] [Server thread/INFO]: Preparing start region for level 0
[11:07:14] [Server thread/INFO]: Preparing spawn area: 32%
[11:07:15] [Server thread/INFO]: Preparing spawn area: 80%
[11:07:16] [Server thread/INFO]: DSESGH[local:E:acea053e] logged in with entity id 344 at (-132.3669149930625, 71.86436893770396, 20.793998062969738)
[11:07:16] [Server thread/INFO]: DSESGH joined the game
[11:07:16] [Server thread/INFO]: Changing view distance to 8, from 10
[11:07:17] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program gbuffers_textured_lit
[11:07:20] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program composite

Thanks!
 

_Luk

Designer
Staff member
Designer
Mar 1, 2014
566
1,031
53
18
Germany
Languages
German (nativ), English, polish, a very little french
#7
This is the important part, as far as I know:

[11:07:17] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program gbuffers_textured_lit
[11:07:20] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program composite

The rest of the crash log is in this spoiler, just in case it helps
[11:06:33] [main/INFO]: Loading tweak class name optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Using primary tweak class name optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Loading tweak class name shadersmodcore.loading.SMCTweaker
[11:06:33] [main/INFO]: Calling tweak class optifine.OptiFineTweaker
[11:06:33] [main/INFO]: Calling tweak class shadersmodcore.loading.SMCTweaker
[11:06:33] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[11:06:34] [main/INFO]: Setting user: DSESGH
[11:06:34] [main/INFO]: (Session ID is token:67bea4fb8df049108def3bbff17b3473:e5f1da93b135488abd361cff4631120e)
[11:06:35] [Client thread/INFO]: LWJGL Version: 2.9.1
[11:06:36] [Client thread/INFO]: Reloading ResourceManager: Default, Gondor.zip
[11:06:37] [Sound Library Loader/INFO]: Sound engine started
[11:06:39] [Client thread/ERROR]: Using missing texture, unable to load minecraft:textures/blocks/97.png, java.io.FileNotFoundException
[11:06:40] [Client thread/INFO]: Created: 1024x512 textures/blocks-atlas
[11:06:43] [Client thread/INFO]: Created: 512x256 textures/items-atlas
[11:07:13] [Server thread/INFO]: Starting integrated minecraft server version 1.7.4
[11:07:13] [Server thread/INFO]: Generating keypair
[11:07:13] [Server thread/INFO]: Preparing start region for level 0
[11:07:14] [Server thread/INFO]: Preparing spawn area: 32%
[11:07:15] [Server thread/INFO]: Preparing spawn area: 80%
[11:07:16] [Server thread/INFO]: DSESGH[local:E:acea053e] logged in with entity id 344 at (-132.3669149930625, 71.86436893770396, 20.793998062969738)
[11:07:16] [Server thread/INFO]: DSESGH joined the game
[11:07:16] [Server thread/INFO]: Changing view distance to 8, from 10
[11:07:17] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program gbuffers_textured_lit
[11:07:20] [Client thread/INFO]: [CHAT] [Shaders] Error : Invalid program composite

Thanks!
I had this problem before too, i've reinstalled all mod with a newer version, at the end i realised that the probleme came from a seus shader pack :p (it was such a review version)
 

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#8
this tutorial might help:
I changed the "float timePow = 2.0f" to "float timePow = 3.0f" and that got rid of the invalid program composite error. However, I still have the invalid program gbuffers_textured_lit error. Does anybody have a fix for this one?

EDIT: I've done a bunch of searching but nobody seems to have a fix for it:(
 
Last edited:

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#9
I found out what the problem was:D I shall write it here for all of you who may be having the same issue:

So, my computer came with bad Intel Integrated Graphics (which I wasn't aware of) and a good NVIDIA GeForce 840M (which I was aware of). As it turns out, the computer was using the Intel one. To fix it, you can go to NVIDIA control pannel, then Manage 3D settings, and change the default gpu from Auto-Select to NVIDIA:)

Someone can lock this thread now;)
 

TheVinci

Aspiring Commoner
Mar 1, 2014
8
0
3
20
#10
So I'm going to start by saying that I am a complete noob when it comes to this, which is why I'm asking for help

During this server crash I thought I'd install shaders, sense I haven't done that yet. I've been at it for at least an hour now and I never could manage it. Can someone help me? Please?
 

TheVinci

Aspiring Commoner
Mar 1, 2014
8
0
3
20
#11
So I'm going to start by saying that I am a complete noob when it comes to this, which is why I'm asking for help

During this server crash I thought I'd install shaders, sense I haven't done that yet. I've been at it for at least an hour now and I never could manage it. Can someone help me? Please?
Never mind, I found out how to do it. Can you switch back to 1.7.9 though? (with shaders)
 

DSESGH

Hardcore MCME-er
Mar 2, 2014
1,218
1,793
50
#12
Never mind, I found out how to do it. Can you switch back to 1.7.9 though? (with shaders)
I don't believe so, because there is not a GLSL Shaders Mod for 1.7.9.

@q220, can you change TheVinci's name to InfinityMe123?
 
Status
Not open for further replies.